Welcome, Guest!!
follow us on... rss

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - macgig

Pages: [1]
1
BotScout Discussion / botscount api mod for smf
« on: December 25, 2012, 02:18:04 PM »
once I install this mod, do I need to do something else? enter an api key? if so where do I enter it?

thanks.

2
BotScout Discussion / Re: unable to install on an smf 2.0 forum...
« on: July 06, 2011, 04:40:52 AM »
cant' edit my posts...

since Im unable to do this step, does this mean the mod is not installed?

3
BotScout Discussion / Re: unable to install on an smf 2.0 forum...
« on: July 06, 2011, 04:37:01 AM »
could be a human, I was thinking the same thing... you are right, nothing will work 100% of the time. :)


here is step 4 in the read me file... which I can't do, cause I am unable to find this code to edit in the register.php file


4) Open the file in the Sources directory named "Register.php". Search for this code in the function named "Register2()":


   foreach ($_POST as $key => $value)
   {
      if (!is_array($_POST[$key]))
         $_POST[$key] = str_replace(array("\n", "\r"), '', trim($_POST[$key]));
   }


Directly below this code, add these lines:

   ////////////////////////////////////////////////////
   // BotScout.com "BotBuster" check
   include('/path/to/your/forum/Sources/BotScout.php');
   ////////////////////////////////////////////////////

Change the part that says "/path/to/your/forum/Sources/" so that it goes to the same directory you placed the "BotScout.php" file in under Step 3.


4
BotScout Discussion / Re: unable to install on an smf 2.0 forum...
« on: July 06, 2011, 03:46:28 AM »
had one join the other day, Just one since upgrading to SMF 2.0. Im told captcha is useless, bots can get past it.

Im unsure if I installed this mod right... I installed using the package manager in smf... all seems to have worked well.... I put my API key in the BotScout.php file. But in my forum admin area, it's saying this is an older version? I don't know, installing is a bit confusing....

I did not do step 4 in the readme file... I cant find the code. I copy and paste, search for the code, it's not there. ???

 ??? ???

5
BotScout Discussion / Re: unable to install on an smf 2.0 forum...
« on: July 03, 2011, 06:55:51 AM »
since updating to smf 2.0, the bots are still on the forum, but they have been unable to make an account. at least so far.  ;D

6
BotScout Discussion / Re: unable to install on an smf 2.0 forum...
« on: July 02, 2011, 11:50:19 AM »
 there are two versions and different install instructions from the txt file included and the instructions of the smf site. little confusing. not sure if I did it right or not. probably just wont bother for now. thanks anyways.

7
BotScout Discussion / Re: unable to install on an smf 2.0 forum...
« on: July 02, 2011, 11:27:13 AM »
which version do I install for smf 2? the one on this site or on the simple machines site? thanks. :)

I have a test forum, id be willing to install and send a screen shot with the error.

8
BotScout Discussion / unable to install on an smf 2.0 forum...
« on: July 02, 2011, 07:46:16 AM »
instructions on smf's site says to edit this file...

Themes/default/languages/Modifications.english-utf8.php

Problem is, that file don't exist.

does that mean I cant use this mod? sure seems that way... I installed editing the files I do have. then I tried creating a new test account... got an error... in a panic, I undid everything.... should have grabbed a screen shot of the error but did not.

Pages: [1]